更新了ADT 20后,新建项目到最后一步时,出现了错误,环境为Ubuntu 12.04 + Eclipse 4.2.0

描述如下:

this template depends on the android support library,which is either not installed,or the template depends on a more recent version than the one you have installed。 Required version :8

根据提示我点 install/upgrame ,下载了一些东西,但安装后console里面显示的是没有权限。

于是进入终端,cd到android sdk的目录,然后 # sudo chmod 777 android-sdk-linux/ -R

再次新建项目,问题解决。 后来谷歌了一下,发现有不少人出现了这个错误,解决方法也不同,如果我上面的方式不能解决你的问题,请看这里: http://code.google.com/p/android/issues/detail?can=2&start=0&num=100&q=&colspec=ID%20Type%20Status%20Owner%20Summary%20Stars&groupby=&sort=&id=33859